1982-1993 Mustang GT Registry - www.mustanggt.org
Dedicated to the documentation and preservation of
1982-1993 Mustang GT's
since 1994!!
Home | About Us | REGISTER your 1982-1993 Mustang GT!! | GT Registry Statistics | Info By Year | Reference Gallery
Forums | Classifieds | Interactive Decoders | Production Numbers | GT Articles | Factory Literature | Info Needed | Donations
This message board and web site has been made possible through donations from: List of Contributors THANK YOU!!!!   
1982-1993 Mustang GT Registry Message Board  

Welcome to the 1982-1993 Mustang GT Registry Message Board!!

We're glad you're here! You are currently viewing our boards as a guest which gives you limited access to view lists of topics, our GT Registry articles & information and access some of our other FREE features. By joining our community, you will have access to read and post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact support.

Go Back   1982-1993 Mustang GT Registry Message Board > General Tech > Maintenance, Troubleshooting and Diagnosis
Register FAQ Members List Referrals Calendar JavaChat Mark Forums Read
Info NEEDED!!REFERENCE GALLERY!!REGISTER your 1982-1993 Mustang GT!!GT Registry StatsInfo By YearAbout Us

Maintenance, Troubleshooting and Diagnosis Need help? Having troubles with your GT? Need some maintenance tips? Ask your questions here.

Reply
 
Thread Tools Display Modes
Old 07-18-2015, 08:17 AM   #1
Robbie
Member
 
Robbie's Avatar
 
Join Date: Sep 2007
Location: Louisville Ky
Posts: 96
Default Power window maintenance

Hello guys after three years without a mustang I've finally found my soul mate.
85 G.T. vert with 34K actual miles! new waters for me....
Anyone replaced the rear window motor and is it hard to do? I lowered it and it stayed down. I can hear the motor running when I press the button.
Thanks
Robbie is offline   Reply With Quote
Old 07-18-2015, 11:06 PM   #2
Shakerhood
Senior Member
 
Shakerhood's Avatar
 
Join Date: Mar 2006
Location: Ohio
Posts: 1,014
Default

Sounds like the Regulator is bad if you are hearing the motor running.
Shakerhood is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

| Home | Info by Year | Register A GT | Statistics | Resources |
| Classifieds |


All times are GMT -5. The time now is 05:06 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.