1982-1993 Mustang GT Registry - www.mustanggt.org
Dedicated to the documentation and preservation of
1982-1993 Mustang GT's
since 1994!!
Home | About Us | REGISTER your 1982-1993 Mustang GT!! | GT Registry Statistics | Info By Year | Reference Gallery
Forums | Classifieds | Interactive Decoders | Production Numbers | GT Articles | Factory Literature | Info Needed | Donations
This message board and web site has been made possible through donations from: List of Contributors THANK YOU!!!!   
1982-1993 Mustang GT Registry Message Board  

Welcome to the 1982-1993 Mustang GT Registry Message Board!!

We're glad you're here! You are currently viewing our boards as a guest which gives you limited access to view lists of topics, our GT Registry articles & information and access some of our other FREE features. By joining our community, you will have access to read and post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact support.

Go Back   1982-1993 Mustang GT Registry Message Board > Other Topics > Humor
Register FAQ Members List Referrals Calendar JavaChat Mark Forums Read
Info NEEDED!!REFERENCE GALLERY!!REGISTER your 1982-1993 Mustang GT!!GT Registry StatsInfo By YearAbout Us

Humor Post your funny stuff here! Videos, Jokes, you name it! Please keep it clean!

Reply
 
Thread Tools Display Modes
Old 08-23-2014, 09:05 AM   #1
wydopnthrtl
Senior Member
 
wydopnthrtl's Avatar
 
Join Date: May 2011
Posts: 337
Default Hey guys, please help with my mods gone wrong.....

Hey guys, I've got a 84 SVO. I've had a K&N panel in it for a while and wanted to get more power. My friend recommended to port and polish the intake and exhaust. We found out they used abrasive material to do it like gritty sand. So I got with my other friend that tunes toyotas and we decided to try it ourselves. We got a bag of sandblasting sand and hooked up into the intake and started the car. We had to hold the gas down a lot so it would run. He wanted to let the engine suck in the sand through the intake so it would port it out and then push it out the ehxaust so it would port the exhaust side too.
I was worried that it might cause problems but he figured it'd be OK as long as we didn't make boost and it get sucked in the turbo. After running the car and letting it suck in sand we got about half way through a 25 lb bag. The check engine light was on and the engine was bucking and kicking and sounding really weird. We stopped and hooked the car back up normal and took off the sand supply. We tried to start it again and it was really hard. Once started it couldn't idle and kept making weird noises. We took it out and drove it and it started to make scraping and knocking noises.
Help! Can anyone tell me what to do? My buddy only does Toyotas so he doesn't know much about these old fords.


__________________
He who is enslaved to the compass is free to sail the seas.
wydopnthrtl is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

| Home | Info by Year | Register A GT | Statistics | Resources |
| Classifieds |


All times are GMT -5. The time now is 08:12 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.